AutoLab Support

We are testing the Disqus comment system below to avoid spam heavy bulletin boards.

You can also use Reddit to discuss support issues with your fellow AutoLab enthusiasts.
http://www.reddit.com/r/AutoLab/

  • nickmarshall9

    Post any support related Q&A here.

    • Jennifer Bellucci

      Hello Peeps,

      Installing Autolabs for the first time. Installed NAS, Router & DC without any issues. Then started on the first hosts and get the error that it could not mount the NFS share, image below. I restarted the NAS, made no difference. I logged into the webgui for the NAS and all permissions for nobody (guess that means everybody) is set to the same as everyone else. I can map drives, etc fine to the NAS. Just this NFS issue stopping progress. Can someone please provide some guidance? I am using defaults on everything, so just booted NAS, DC, router. Made no changes to them at all apart from increasing RAM on NAS to 1GB.

      • Jennifer Bellucci

        image

        • Jennifer Bellucci

          Fixed the problem.
          Started from the beginning again. Unzipped archive and then went about building as usual. I then configured the software firewall to explicitly permit 192.168.199.0/24 communication to any other network and on the router VM I set the bridged interface to the Internet VLAN. Router+DC+NAS+VC+3x hosts installed.

          Can someone tell me how to install additional ESXI hosts? I see the option to install host4 but there is no host folder in the archive like there is for hosts1 to 3.

    • Jennifer Bellucci

      Does anyone know how to add more hosts properly? I managed to get hosts 5 and 6 added and installed via PXE but the NFS and iSCSI shares are missing. I am thinking I will need to edit the powershell scripts for this to work properly, it must be looking for 1-4 hosts only.

  • Testing Testing.. 1,2,3.

    • nickmarshall9

      I think this should work ok.
      If and when there’s enough traffic I’ll buy some “proper” forum software.
      PHPBB was just too hard to maintain / keep the spam out.

      • Amadoukholle

        Database missing for Vcenter and Update manager

        “Shared memory provider: Timeout error [258]” then the error was one of timing.

        what do you think about this. it is asking to me to edit b:UnattendDCPhase2.cmd but

    • Amadoukholle

      Database missing for Vcenter and Update manager

      “Shared memory provider: Timeout error [258]” then the error was one of timing.

      can u please advise

  • Which iso version of Windows 2k3 is required? Will 2k8 R2 work without changing scripts?

    • The Win2k3 is for an internal VM build after the AutoLab is ready. Yes, a few weeks ago I rebuild AutoLab with an 2k8R2 without problems.

  • Nick Bodmer

    I’m in the process of setting up a 5.5 Autolab. After the VC installs, when I try to connect to the vSphere client via the “vSphere” shortcut, I receive the error “The vSphere Client could not connect to “vc.lab.local”. You do not have permission to log into the server: vc.lab.local.” It is attempting to use the username “LABvi-admin”. I’ve also tried manually entering the username/password (as defined in the as built documentation) but I receive the same error. Validating the server build reports “Build looks good”.

    • Nick Bodmer

      I think I may be having a problem with VM creation as part of the “Add ESXi Hosts to vCenter and configure cluster”, not sure if related. Here is the error from powershell: http://pastebin.com/Yx3DMBmG

      • Nick Bodmer

        New-VM : Cannot bind parameter ‘Version’. Cannot convert value “v9” to type “VM
        ware.VimAutomation.ViCore.Types.V1.VM.VMVersion” due to invalid enumeration val
        ues.

        • Roger Kohler

          I have the same problem with not being able to log in. I found reference to a work around, that worked once and can’t get it to work again. Did you fix it? The work around I found is documented in the blog post by Kyle Gleed: http://blogs.vmware.com/vsphere/2013/09/vcenter-single-sign-on-5-5-not-recognizing-nested-active-directory-groups.html

          However I can’t even see the Domain Admins.

          • Nick Bodmer

            My problem was that I did not use the latest version of VMware powercli tools. Make sure the version matches the version of venter.

          • Roger Kohler

            Interesting observation. I think all my versions are compatible, but I will double-check. Thanks for the tip. If its really that sensitive, then the AutoLab or VMware should post a list of compatible versions of the tools somewhere including vSphere, vCenter, CLIs, vCloud, etc. Does it exist somewhere?

          • Nkwachi Ogwuma

            Login to Vsphere client with local admin account “vcadministrator” password “VMware1!” and grant permission to LABvi-admin

          • Nick Bodmer

            Sorry, if you are having the log in problem, just log into venter with the account “administrator”.

          • Roger Kohler

            I was logging in with administrator and I cannot see the vcenter server in the inventory. When I use the vSphere Client shortcut on the desktop which uses the LABvi-admin account it doesn’t login because the LABDomain Admins have no permissions on the vCenter server. It is a known issue, I just can’t seem to use the work around.

    • Nick Bodmer

      Per @DemitasseNZ:disqus, The issue here is that SSO 5.5 doers not add the http://Lab.local domain & adding it cannot be scripted

  • Amadoukholle

    I am having issues with Vcenter update manager not installed and vcenter database missing. can anybody help with that

    • Any error message that you can post the get an idea?

  • Amadoukholle

    Database missing for Vcenter and Update manager

    “Shared memory provider: Timeout error [258]” then the error was one of timing.

  • Amadoukholle

    i am being ask to edit this file which I can’t locate b:UnattendDCPhase2.cmd

    • You can edit that file connecting to the buildshare. there is a Automation folder that has all the scripts used to build autolab.

  • Steve

    So I finish installing AutoLab 1.5 (Workstation 10), this is a 5.5 install (vCenter and Hosts). I can’t log into the thick client but I can get into the Web client. My issue at the moment is that there is nothing listed in my inventory and there seem to be no way for my to add to the environment (right-click to add doesn’t work on any location). The validate script looks good, all green and have full network connectivity. Anyone else run into this issue? Is AutoLab really being used anymore?

    • From the vCenter VM there is an script in the desktop that has option for add the ESXi to the inventory. Did you run that?

    • Justin Allen

      Who are you logging in as? you may need to login as Administrator@vsphere.local and add your domain account to the vCenter “Administrator” group and then log back in as your domain user.

    • Joshua

      I, too, am getting the very same issue as Steve describes above. I did re-run script #3 – adding hosts to the vCenter server (as Ariel mentions below) – still getting the same result. The user “vi-admin” is a member of the ESX Admins group in AD. I’m unable to authenticate with the vSphere client, but when I log in via the web client, nothing is populated.
      During the actual setup and build out process – all went very smoothly. I followed the Lab Guide pdf very closely… also watch the vHersey videos.

      • MarkD

        I came across this same issue a few weeks ago when I installed the lab as the lab documentation didn’t contain the administrator@vsphere.local password. I uninstalled the vCenter components on the VC server and reinstalled them without overwriting the database so that I could set a known password for this account. Since then I found this note on Hersey’s video page AutoLab Video Series Part 4 https://www.youtube.com/watch?v=HcBo7fTbwrc which says:
        “A quick note: The administrator@vsphere.local SSO user password is missing from the AutoLab documentation. The password for administrator@vsphere.local is VMware1.lab and you will need this to log in to the AutoLab environment for the first time to add LABAdministrators to the vCenter permissions so you can log in to the environment as LABvi-admin. Once LABAdministrators has been added with the Administrators role you will be able to log into the lab as LABvi-admin.”
        I haven’t tested this password as I’ve already reinstalled my vCenter, but it may be the solution.

        • Steve

          This fixed my issue, need to the administrator logon to add LABvi-admin.

        • I added the labvi-admin user to vcenter (vc.lab.local) with the administrators roll. Worked for me.

  • Justin Allen

    Hello All, I’m receiving the following error during the initial ESXi Host boot. “/ESXi55/ata_pata.v00: file not found. Fatal error: 15 (Not Found)”. I do have both the NAS and DC running, and had no complications setting those up. Also I’ve verified that the ata_pata.v00 file does exit in the esxi55 share. Any help would be greatly appreciated. Thank you

    • Matt Jones

      I am having the same issue. The install of 5.1 goes just fine though. I have tried 3 different versions of 5.5 to no avail.

      • Martin Rennix

        I get the same error with 5.5. Auto build does not work.

        • Martin Rennix

          Found the fix. The error occurs with the rollup version of the 55 iso. You need to use the non-rollup iso. Also, you need to rebuild the DC to pick up the new extracted 55 files (they get copied to the TFTP-RootESXi55 folder on the DC).

        • Matt Jones

          I figured it out. I had to download the vanilla 5.5 ESXi iso. Not update 1 or update 2. Make sure you get the same build for the vcenter server because that will fail too if you don’t. Delete out what you have in the NAS build share and then replace it with the ESXi image as well as the vCenter Server.

  • john stokes

    Hi All,
    I dont know it the last post went thru (apologies on repeating myself if it did) but I am having trouble with the zip file.
    When I downloaded it showed as empty so nothing to extract.
    I want to set up the 5.5 lab for the vcap-dca
    I had previously extracted the lab but it came thru in ovf format.
    Is the only way to run the ovf wizard thru esx or vc?
    I’m planning to run everything on WS10.
    Thanks for any help on this.

  • Vedran

    To say that AL is brilliant would be an understatement. It helped me immensely to prepare for VCAP5-DCA exam. Keep up the good work!

  • Felix Kane

    Autolab installed with success.
    I will now download the VCP exm blueprint and start doing lab, lab lab…

    I will redo the lab but this time will do everything manually.

    • nickmarshall9

      Would it help if I set out some guides that stepped through the VCP exam blueprint?

      • Felix Kane

        Yes. A guide that steps through the VCP exam blueprint will be very helpful.

      • lexone

        Absolutely! Please do!

  • Safeec

    I have downloaded Autolab 1.5 version. after power on NAS, i cannot access the build share

  • Robert Schnitzlein

    When I setup my Domain Controller, it is configured to have the IP address 192.168.199.4, however when I run ipconfig/all it doesn’t reflect that (sorry didn’t grab it, but it started with 169.x.x.x. I have to manually change the IP address to something else to get on the network. Obviously my build script fails since it can’t reach the NAS VM. After fixing the IP address I can manually kick off that script. However other steps of the build script are expecting this VM to be .4, and fail.

    What is wrong with windows? Am I using the wrong DVD? Both en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_debug_checked_build_x64_dvd_408075.iso and en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_debug_checked_build_x64_dvd_619600.iso had this behavior.

    What would cause this odd behavior?

  • Mark Daniels

    whilst building the vcenter server get the following error when installing SSO: (running on ESXi without DRS)

    there is a problem with this windows installer package.a dll required for this install to complete could not be run

    • Martin Rennix

      See my post above, here’s what you need to do if you get this error:

      Press CTRL-C to exit the script, and exit the error
      dialog. Run “vcredist_x64.exe” and vcredist_x86″ from the
      \192.168.199.7BuildVIM_55Single Sign-Onprerequisites folder.
      Start the VC script again by running
      \192.168.199.7BuildAutomateVCbuild.cmd, make sure to right click
      and “Run as Administrator”. You will get a PowerCLI error, press ENTER
      to continue. SSO and all other modules should now work.

  • Charles Windom

    Getting an error when trying to deploy AutoLab v1.5 on vSphere v5.5 U1. Seems to error out when trying to deploy the second disk. I have re-downloaded the software atleast 4 times and all is okay with the zipfile. I am attaching a screenshot of the error. Forgot to mention this is with DRS enabled.

  • Martin Rennix

    This is how I got vSphere 5.5 U2 working in Workstation 10.

    1. Make sure you use the non-rollup iso of ESXi 5.5 U2. The DC and ESXi hosts should build ok.
    2. During the VC auto build if the SSO install fails with a “DLL not found” error then press CTRL-C to exit the script, and exit the error dialog. Run “vcredist_x64.exe” and vcredist_x86″ from the \192.168.199.7BuildVIM_55Single Sign-Onprerequisites folder.
    3. Start the VC script again by running \192.168.199.7BuildAutomateVCbuild.cmd, make sure to right click and “Run as Administrator”. You will get a PowerCLI error, press ENTER to continue.
    4. The VC and all modules should install correctly now.
    5. Run the “VMware vSphere Client” shortcut on the desktop and log in as vcadministrator, password VMware1!.
    6. Add LABadministrators to the Adminstrator role at the VC level.
    7 Now you can run the vSphere shortcut on the desktop which logs you in as vi-admin.
    8. Run the AutoLab Script Menu and select option 3 to add the ESXi hosts and create networks and datastores (if using the default automate.ini).
    9. I didn’t need to select option 4 (add route to the internet) as the VC already had it’s gateway set to 192.168.199.2

    That’s it!

    • Aaron Lewis

      Thanks! This was very helpful.

    • lexone

      Nice work! I added some lines to the build script to run these 2 files first before running the PowerCLI installer. :)

    • Dave Tidwell

      What is the best version of autolab to use if you do not want to use vSphere 6 and only want to use 5.5u2? Is autolab 2.0 better than 2.6 for vsphere 5.5u2? Martin, if you can let me know what version of autolab you used, I would appreciate it.

      • Martin Rennix

        Hi Dave, pretty sure I used 1.5 with ESXi 5.5U2.

  • Matt

    Trying to install player according to the labguide and it does not like “rundll32.exe vmnetui.dll VMNetUI_ShowStandalone” fails to start saying the vmnetui.dll module could not be found. Any body else with this problem?

  • Pat Denis

    Hi ! , trying to setup the lab .. am using esxi have 2 server .. instead of using vmware workstation ? could i simply import all the file in esxi ? if yes how ???

    • lexone

      There are instructions in the lab guide for deplying this on an ESXi server instead of Workstation or Fusion.

  • Steve

    Complete n00b question… I was wondering why the drive mappings for Host2 don’t match the drive mappings for Host1? I used the automated build process provide in autolab. The first pic is for Host1, the second is host2.

  • jkellner

    I just started with the lab guides deployment but when I get to the VCenter piece and power on the 2008 server, the system runs through the script but never auto logins properly. I receive an error that the username and password is incorrect. I tried to change this in the DC to VMware1! but still no luck logging in, Any ideas, Has anyone seen this? Thanks

    • Joseph Kasal

      I had the same issue after the base windows OS was built. It was attempting to login as vi-admin. What I did was logged in as Administrator with the VMware1! password and then everything worked. The scripted continued to run through the process and never had the issue again.

  • pedro

    Hi Nick and Team

    I´m de deploying the lab, and everything is working as expected, except two things on the road, I can not activate Windows Server to 180 days trial, I don´t know why is this happening..

    Thanks in advance, so glad to have this to help my road to VCAP…

  • lexone

    Anyone else getting a constant installation loop on the VC VM using W2K12 once build has completed in AutoLab 2.0? After final reboot, VM performs auto-logon then kicks off the build script and starts installing all over again.

    • Ed Monger-Rue

      No sadly I can’t get that far. I’m getting a error about the in the unattended file.

      I added the product key to the automate.ini file, is there another location it should be added?

      I’m also testing with 2K8 now to see if that works any better.

      Cheers,
      Ed

      • lexone

        I managed to figure out what the issue is. For some reason it was reading in an entry from the automate.ini file for the View installation since I had the file in the view folder and it added an entry to the Run key in the registry to execute the build script. Once I removed it, problem solved.

        As for your issue, the product keys that you are entering should be for the 2003 or XP VM’s for the View installation. If your are not trying to also build the view VM then do not enter any product keys. The Autolab is only configured to use those 2 OS’s for View so 2008 will not work. 2008 & 2012 only work for the DC and VC VM’s. Could you upload a screen shot of your automate.ini file? Feel free to blur our or remove any product keys

        • Ed Monger-Rue

          I have reverted back to the canned / default automate.ini; I just changed the TZ.

          This appears to be working with Win 2K8. Once the 2K8 installation completes I’ll check 2K12 again.

          [Automation]
          TZ=Pacific Standard Time

          VCInstall=55
          VCInstallOptions=4,5,51,55,58,None,Base
          AutoAddHosts=False
          AutoVCNS=No
          DeployVUM=True
          Adminpwd=VMware1!

          BuildDatastores=True
          BuildVM=true
          BuildOptions=True,False
          ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

          ViewInstall=None
          ViewInstallOptions=50,51,52,53,60,None
          BuildViewVM=true
          ViewVMProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

          KMSIP=0.0.0.0

          • Ed Monger-Rue

            No joy with 2012. On the same VM (DC) that 2008 just worked with.

          • lexone

            Strange, and you are not entering any product keys for the operating system, correct? Also, be sure that you are using R2 versions of 2008/2012

          • Ed Monger-Rue

            Yes, here are the ISO versions:
            en_windows_server_2008_r2_with_sp1_x64_dvd_617601
            en_windows_server_2012_r2_x64_dvd_2707946

          • Ed Monger-Rue

            I also tried with a physical ESXi 5.5.0 cluster and the en_windows_server_2012_r2_x64_dvd_2707946.iso. Same issue.

          • Mike Davis

            Bump the memory of the DC up from 512 to at least 1GB.

        • internet xplorer

          Hi lexone, I have the same issue. After a reboot of the VC server the buildscript kicks
          in and tries to do it all over again. I have read your solution but
          don’t quite understand what you removed exactly? There is a file in tthe
          V1 folder within the Automate folder, I removed it from this folder but
          without succes.

          • lexone

            Hi @internetxplorer:disqus, apologies for any confusion and I hope this is more clear. Do not remove any actual files from any folders. What I meant that was removed was an entry from the automate.ini file. Inside of this file, you configure it for your build by setting numerical and true/false values which are then “read in” by the scripts to configure and build your AutoLab environment. One of the entries in the automate.ini file is for installing VMware View, and I had placed the necessary files for the “View” installation inside it’s respective View “version” folder. I removed these files from said folder and set the value to False/Null or left it blank in the automate.ini file (I can’t remember as I have the lab shutdown at the moment). I hope this help to clarify for you.

          • internet xplorer

            No worry’s and thanks for the reply :-)

            It didn’t matter what I did in the automate.ini or which files install files I removed the build script eventually always kicked in. To solve this I had to delete te registry string that initiates the build.cmd.

          • lexone

            Ahhhh yes!! Now that you mention it I forgot about that. I actually changed this as well. What you can do is edit that registry line that calls the build.cmd to use “RunOnce” instead of “Run”. Then after it’s been run the first time, it will remove itself from the registry so it doesn’t “build loop”

  • Pete

    I am having an issue

    Running VMware Workstation 10.0.1 on OpenSuse 10.3. Using Autolab 2.0 with 5.5.

    I am having an issue where the Datastores did not get added to the Hosts. Also, I am getting some HA errors saying it cannot reach the isolation address.

    Now the one common factor is that all the address are in the 172.17.199.x and 172.16.199.x range. I went to the NAS and tried to ping from there and I got no response. vmnet3 was setup as 192.168.199.x but I would assume these ranges still work, they would just not be routable.

    I saw some funky stuff that had to be done to get this working on Fusion on the MAC, and I am wondering if there is anything I am missing by trying to get this to run under Linux.

    Any ideas? Help?

    • pedro

      The same as me, still no answer, still working the issue!! Pet, did You get anything?

      Regards

      • Pete

        Actually, I figured this out in the end.

        The VMnet3 device setup in Linux is owned by root/root. I run VMware workstation as a local account. I changed the rights to the vmnet3 network adapter to root/everybody and then it worked ok. It was trying to set the NIC into Promiscuous mode when ESXi boots, which it did not have rights to do since I was not running as root.

        I did noticed that it did not “stick” I had to set it again after a reboot of the main linux machine.

  • Joseph Kasal

    Anyone run into an issue where you can not login to the ESXi hosts after a reboot? I get a 503 Server Unavailable on all the ESXi hosts. I have checked disk space, restarting services, etc. Nothing is glaring in the host logs either. A few Socket connection errors but nothing to explain them.

  • Jamie Schultz

    I have a question about VSAN and how you went about presenting the disks to the nested hosts. How did you make the 5GB disk appear as SSD and the 40GB appear as Non-SSD? I have an issue with one of the hosts that is showing 0 of 2 disks in VSAN and the 5 and 40GB disks show as SSD. i think that may be why. Anyway, looking at your scripts i couldnt find anything and not sure how from the vcenter side certain disks appear as SSD. Any insight is appreciated. I tried a rebuild of the host and that didnt seem to work either.

  • pedro

    HI all

    I go a little problem, I have built the 2.0 version of autolab in my MacBook Pro retina, with Fusion, everything is ok except, that I can not reach from vCenter the 172.7.199.17 of the NAS, so this way I can not mount NFS volumes, neither ISCSI wich is the same IP address, some of you can figure out what am I missing here? 1 month for Delta exam… running out of time

    Thanks in advance, while I´m keep on make some troubleshooting

  • Ken Michiels

    Running into the issue where auto deploy of ESXi 5.5 throws the fault [Error 2] No such file or directory ‘/tardisks/xhci_xhc.v00’ . Can someone lend me a hand…

    • electron1960

      I’m getting the same error. Has anyone moved past this

  • Rob

    I’ve everything up and running. The VC setup is valid and the cluster is created. But now my cluster says that the VC can’t communicate with the HA agent of the hosts.
    What do I need to do? I can ping the hosts from the VC, so connectivity is fine.

    I’m running in Fusion.

  • Norman

    Hi, I have tried both ver 1.5 and ver 2.0, I am using VMware workstation 10.04, with 8-core and 32G RAM, ESXi 5.5.0, when I use Veeam v7, I could not install Veeam One, more specific, on step 11 on pg60, the login was rejected. This was the same case when I used ver1.5 two month ago (ESXi and everything else the same version as in December) I don’t know anything about SQL and less experienced with Windows Server 2008.
    Does anyone go as far I did? How is the Veeam One installation?

    • DaylenDOA

      Go into vCenter and under the Permissions tab right-click in the white space. Select Add Permission… Change Assigned Role to Administrator and then click Add… For the Domain drop down select Lab and then look for the SVC_Veeam user and double-click. Click OK and then try to add the vCenter Server.

      Probably overkill with the permissions, but it finally worked for me then.

  • Mathew Maybee

    How to Install Autolab without DRS on a single ESXi 5.5 host – hi there, I received a really kickass production server for free, so I was hoping to run with this Autolab setup for my VCP5 studies. The instructions (and my apologies if I missed something) seem to cover the setup that uses DRS (and the deployment functions of vsphere), so I’m wondering if there are instructions or videos on how to do the setup without DRS. There is a reference saying this build is much more work which I am okay with, but I think I must be missing something. Any help or guidance would be awesome, and again, apologies if I have missed something obvious! (I should mention I am using version 2 of the Autolab)

    Cheers

    • lexone

      Check the lab guide again, Section 4, pg. 16

      • Mathew Maybee

        Apologies, should have clarified that I had seen that part of the document , but am unsure how to correctly configure the non drs package…I ran up the lab successfully on my win 8 laptop, but I seem to miss the esxi instructions…

        • lexone

          Pages 6-7 & 15. Any particular reason why you want to deploy non-DRS? If you are installing on a single ESXi host you can deploy the DRS version. I can confirm this as that is how I run my lab setup. There’s really not much to it. I have a video I created for the 1.5 deployment and will be working on an updated 2.0 video soon. It should help you out. Check it out and please show your support by giving a thumbs up!

          • Mathew Maybee

            I was thinking the non-DRS version as I was under the impression that the DRS version required a full vcenter implementation (along with a DRS cluster) to set up. But I did see that this lab can be a nested setup so I will give your video a watch shortly. Many thanks for your help thus far, I’m not very familiar with this stuff yet, and tend to ask lots of questions in order to learn about it :)
            Cheers!

  • Larry Bell

    I am seeing some unusual behavior. I just finished setting up vCenter and I am seeing JAVA running multiple processes and using 100% of my CPU. Any ideas? installed on server 2008 r2

  • David Frederick

    Hi all – for those trying to install vSphere 5.0 using AutoLab_2.0_Workstation on VMware Workstation, Player, etc… You may find that HA isn’t working. This problem occurs because esx-tools-for-esxi is installed on the hosts; however, that VIB is not compatible since we’re not using ESXi to host the lab. (I suspect that adding this VIB was accidentally included in the scripts for the VMware Workstation version of the 2.0 lab.)

    Here is what I did to resolve the issue:

    (1) Connected to each host using PuTTY and logged on as root.
    (2) Ran this command: esxcli software vib remove -n esx-tools-for-esxi
    (3) Rebooted host
    (4) In vSphere Client, clicked on Reconfigure for vSphere HA on the Summary tab of each host.

    After that, HA installs correctly.

  • Marius Sandu

    Hello guys,
    I have a big poblem,please help me out
    I cant find the pxe boot to install Vcloud…any ideeas?

    • tyrone

      Hi Marius,

      having the same trouble myself , Version 2.0 , found this
      http://nested-vsphere-autolab.googlecode.com/svn/trunk/Build/Automate/PXEMenuConfig.ps1
      wondering if it might do the trick . I don’t see any one else complaining about it so I’m thinking iv’e gone wrong somewhere

      • Marius Sandu

        Dont want to be a noob, but how do i use it? so i have vcloud install in pxe boot?

        • tyrone

          Hi Marius,

          looks like we’re missing some automation, I’ve gone to here : http://code.google.com/p/nested-vsphere-autolab/source/browse/trunk/Build/Automate/DC/TFTP-Root and i’m building the files in on the DC. For vLCoud, in the pxelinux.cfg folder holdes a ‘default’ file , which points to vcloud.menu file, which should start off the auto build. my files are missing some options so i’m building as laid out in that link . I need to create a CentOS folder also in the Automate folder on the share and populate it ..

          • Marius Sandu

            Can you please give me the file you mande and point me to the folder where to store it?

  • disqus_vot2Z0epsw

    Is the “Add route to the Internet” option removed in version 2.0 ?

  • ABHIJEET AGARWAL

    Hello, I am installing Auto Lab, things were good until in installed 3 Hosts, DC and NAS. But when I install VC, I got following error in middle:

    Error 25003.Setup Failed to create the vCenter Server repository. The most common reasons for failure are:

    — The database is installed in Case Insensitive mode
    –The database is remote and the client version does not match…

    I am installing 5.5

  • ABHIJEET AGARWAL

    Hello, I am installing Auto Lab, things were good until in installed 3 Hosts, DC and NAS. But when I install VC, I got following error in middle:

    Error 25003.Setup Failed to create the vCenter Server repository. The most common reasons for failure are:

    — The database is installed in Case Insensitive mode

    –The database is remote and the client version does not match…

    I am installing 5.5

  • ankul bhardwaj

    Hi Guys,
    I’m trying to use Autolab 2.6 on Vmware Workstation 10. When I try to install the Guest O.S. on DCVC VM (Windows Server 2012 R2) I get the error ” Windows could not apply the unattend answer file’s setting.

    Can someone please advise what can be done next?

  • Atul Kalia

    Hi
    Can’t deploy new OVF template. Suggestion, solution please?

  • Jhonny Nemonic

    Hello there gents, I did try to install Autolab 2.6, using w2012 and such but something weird happens when I run the configuration for ESXi host, I just realize that the vlanID for management and for iscsi vmk ports is not added and then when I did manually it is not possible to esxi host to reach the iscsi free nas share, any info will be appreciated.

    • Jhonny Nemonic

      nevermind I solve the problem, thanks!

  • fergi

    I am attempting to deploy hosts one and two from auto lab after configuring the DC and validating it.

    While running the Reading Instalation port it provides an error

    error:nfsL//192.168.199.7/mnt/LABVOL/Build/Automate/hosts/esx2-5.cfg:line 2: Passwords must be at least 7 characters long.

    Has anyone encountered this issue and resolved it?

  • Win Tafe

    Hi guys, just getting started here. When i deployed the autolab ovf i get this error. Using Autolab 2.6 with ESXi 5.0 and the vCenter appliance. Is this an issue?

  • TommyGator

    I just setup Workstation 11. I downloaded the ESX 5.5 rollup just to test installing an ESXi host without the AutoLab and it seems to hang up. Does anyone know if the rolloup is still not working when installing ESXi hosts in Workstation 11

  • haripetrov

    When you try to install Server 2012 on “Lab_DC” VM an error occurs: “Windows cannot find the Microsoft Software License Terms. Make
    sure the installation sources are valid and restart the installation.”
    In order to solve this problem you have to change the memory from 512 MB to 1 GB or more:
    https://blog.workinghardinit.work/2014/09/05/fixing-windows-cannot-find-the-microsoft-software-license-terms-make-sure-the-installation-sources-are-valid-and-restart-the-installation-or-windows-installation-encountered-an-un/

  • Mike

    Hey, are you planning to continue with home lab rebuild video series and if there are any updates scheduled for the autolab itself? :)
    Thanks

  • Syed Moin

    Hi Everyone

    I’m running the ‘Validate’ script on the Windows Server 2008 R2 on Ravello. I get this message ‘vcenter database missing’ (please see attached image).

    Would really appreciate your valuable advise.

    Thanks

  • Brian Hupp

    Hi, I’d like to set up AutoLab on ESXi with DRS. I’ve got my outer ESXi machine built, but I’m a little confused how to create the nested ESXi hosts. Do I need to create them as VMs manually? Also, will I have to deploy a vCenter VM manually first?

    • Alex

      Hi @brian_hupp:disqus, you should follow along with the documentation. None of the VMs need to be built manually. When you download and the correct package for your type of install, you will be presented with an .ova file which contains all of the shell VMs used in AutoLab. After following along in the doc you will fire up the router and NAS VMs as they are pre-built. You will populate the NAS share with the installation media needed to build the ESXi guests along with the DC and VC VMs. I created a video on this back with v1.5 which you should take a look at. You may find it very useful. https://www.youtube.com/watch?v=CoXGQD-2foU

      • Brian Hupp

        Thanks for the great info and video, Alex.
        I guess I didn’t make my question very clear. The issue I’m running into is that when I try to deploy the OVF, I get the following error message…

        The OVF package requires support for vApps with multiple VMs.

        I noticed in your video that you have already created an environment in which you have an outer vCenter running inside a datacenter that includes only your outer ESXi host. The LabGuides instructions say that in order to deploy the Autolab with DRS, I will need a DRS-enabled cluster which also means that I will need to have vCenter running. That was what I meant when I asked whether I needed to deploy a vCenter in my environment first. I’m assuming you did that on a physical server in your environment, and that what I’m seeing in your video is your screen when logged into that vCenter with vSphere client. I’m trying to deploy the Autolab on a single well-provisioned notebook that I can take back and forth to work with me. So I think what I need to do is deploy the Autolab without DRS OVF. I’m assuming once I have the vCenter VM running in the Autolab, I will then be able to set up an HA/DRS cluster of the virtual ESXis, and play with DRS, vMotion, etc. using that vCenter VM.

        I think I’m on the path with that. Thanks again for the info/video.

        • Alex

          @brian_hupp:disqus, ahhh yes, apologies for misunderstanding you then but you are correct. In order to deploy the DRS version you will need to be deploying in an environment that already has a vCenter. In your case, deploy the non-DRS OVF version and once the AutoLab has been built, you can enable HA and DRS within AutoLab and play around with it. Please show your support and give a like to my video and be sure to subscribe to my channel. Best regards!

          • Brian Hupp

            Hi Alex, I couldn’t get your video to load using the link you sent. I watched it from the embed here on the forum. If you give me the URL again, I’ll try to give you the like you asked for.

          • Alex

            Once you start the embedded video here, in the lower right-hand corner there is a YouTube logo. If you click that it will open the video in YouTube and then you can like and subscribe. Here it is below just in case but it will prob insert an embedded video again which I was trying to prevent from happening :)

  • Brian Hupp

    My Win2012 servers (vCenter and DC) were shutting down every hour. This was preventing the VC auto-build from completing. Surfing a little bit, I found this issue is due to the Windows evaluation not being activated. TechNet discussion says I need to run slmgr -ato (which is what the activation option in the autolab vCenter script menu does), but when I do that, I get an error saying that the version I’m running is not a “core” version. A temporary workaround is to run slmgr -rearm which gives a temporary life at least long enough for the VC build script to finish.

    Am I running the wrong version? Has anybody else seen this issue? Is there some way to get the evaluation activation (-ato) to run and keep the evaluation version alive for the whole 180 days?

    Thanks.

    Oh BTW – Autolab is DA BOMB!

  • Brian Hupp

    I’m having an issue with Autolab 2.6. I’m running under Workstation 10, and have pretty much the same setup used to develop Autolab, except for a bigger SSD.

    The problem is that when I fire up the lab, everything appears to be working fine, but when I try to do certain edits in vCenter the operation fails because the hosts are reported as not being in the proper state.

    If I go into the vCenter VM and restart the VCenter service (which also restarts the dependent VCenter Web Management Service), afterward everything works as advertised.

    Is anybody else seeing this?

  • Muhammad toffaha

    error 25003 during install vcenter Server 5.5 what can i do ?

  • al hakimov

    Hello guys,
    I build 2.6 lab in fusion pro 8.1 and all is well until the part when I have to boot ESXi VMs, but it can’t find PXE boot option, I checked DC which has tftp installed according to “Validate” script. Now how do I check if PXE boot is configured and is listening to network subnet 192.168.100 network? I haven’t configured PXE on my own but I guess I can do that but I thought this automated tool should be able to deploy it.

  • Nik Sharp

    How can I change the external address on the router? My external network does not give out DHCP, it is a server vlan where everything has a fixed address. I tried logging into the router using the fresco default of “root” and “root” but this did not work

    • The default username is “root” and the default password is the same as the admin web password “VMware1!”. Once logged in, type “setup”. You will then need to access “(c) Advanced settings” > “(h) Local Networks” and set a static address along with turning off DHCP for eth0.

      • Nik Sharp

        Thanks Alex

  • Ashish Heda

    While Installing DC getting Error that dcpromo.ps1 can not be loaded. I started powershell in Administrative mode and gave the Following command:

    – Set-Executionpolicy -Scope Currentuser
    – Remotesigned
    – C:dcpromo.ps1
    but its showing error that dcpromo file is not found.
    Please Suggest what I need to do.

    Thank You,

    Ashish

  • AKILESH J S

    PowerCLI: Copy-Item : Access to the path is Denied Permission Denied for autolab 2.6 installation…. (self.powercli)
    submitted 23 hours ago by jsakil14
    Now i have powerCLI in my validat e script , but the SQL thing throws out this error on VALIDATE SCREEN : Checking available SQL Express versions. SQL Server 2008 R2 Express SP1 for vCenter 5.5 found; installing. Copy-Item : Access to the path ‘C:tempSQLEXPR_x64_ENU.exe’ is denied. At C:Phase2.ps1:474 char:7 + copy <<<< B:VIM_55redistSQLEXPRSQLEXPR_x64_ENU.exe C:temp + CategoryInfo : PermissionDenied: (B:VIM_55redis…XPR_x64_ENU .exe:FileInfo) [Copy-Item], UnauthorizedAccessException + FullyQualifiedErrorId : CopyFileInfoItemUnauthorizedAccessError,Microsof t.PowerShell.Commands.CopyItemCommand Remove-Item : Cannot remove item C:TEMPSQLEXPR_x64_ENU.EXE: Not Enough permis sion to perform operation. At C:Phase2.ps1:477 char:6 + del <<<< c:TEMPSQLEXPR_x64_ENU.EXE + CategoryInfo : PermissionDenied: (C:TEMPSQLEXPR_x64_ENU.EXE:F ileInfo) [Remove-Item], IOException + FullyQualifiedErrorId : RemoveFileSystemItemUnAuthorizedAccess,Microsoft .PowerShell.Commands.RemoveItemCommand Creating Databases. Start-Process : This command cannot be executed due to the error: The system ca nnot find the file specified. At C:Phase2.ps1:479 char:16 + Start-Process <<<< "C:Program FilesMicrosoft SQL Server100Tools Binnsqlcmd.exe" -ArgumentList "-S dcSQLEXPRESS -i B:AutomateDCMakeDB.txt" -RedirectStandardOutput c:sqllog.txt -Wait + CategoryInfo : InvalidOperation: (:) [Start-Process], InvalidOp erationException + FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.C ommands.StartProcessCommand Start-Process : This command cannot be executed due to the error: The system ca nnot find the file specified. At C:Phase2.ps1:480 char:16 + Start-Process <<<< "C:Program FilesMicrosoft SQL Server100Tools Binnsqlcmd.exe" -ArgumentList "-S dcSQLEXPRESS -i B:AutomateDCMakeDBvCD51. txt" -RedirectStandardOutput c:sqllog.txt -Wait + CategoryInfo : InvalidOperation: (:) [Start-Process], InvalidOp erationException + FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.C ommands.StartProcessCommand Start-Process : This command cannot be executed due to the error: The system ca nnot find the file specified. At C:Phase2.ps1:481 char:16 + Start-Process <<<< "C:Program FilesMicrosoft SQL Server100Tools Binnsqlcmd.exe" -ArgumentList "-S dcSQLEXPRESS -i B:AutomateDCMakeDBvCD15. txt" -RedirectStandardOutput c:sqllog.txt -Wait + CategoryInfo : InvalidOperation: (:) [Start-Process], InvalidOp erationException + FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.C ommands.StartProcessCommand SQL Management Studio not found (optional).

  • John

    Hi, I can’t find the vmware-vcloud-director-1.5.1-622844.bin download anywhere on the internet. Can anyone share a link please?

    • Tracy Hoffman

      I am also looking for vmware-vcloud-director. Did anyone have a link to share?

  • Michael Alves

    Any status on the next version of Autolab? Version 2.6 is getting somewhat dated.

  • jaxdevo

    Just discovered Autolab and wish to setup a lab for vsphere 6 exam prep. Has anyone done a vmware workstation 12 or vmware vsphere 6 autolab 2.6 install? seems like documentation is outdated and would be good it if there was a youtube or other video demonstration, or some help with the gaps in docs. Thanks.

    • jaxdevo

      what i mean using local resources not Ravello as this lab will not have internet access. Thanks.

  • Muhamad Amru Eldan

    I want to prepare for VCP6-NV and i am in the following situation:
    I see that you can deploy the lab using 2 methods Either using ESXI or using Workstation
    My main question is can i apply everything in Workstation instead of ESXI ?
    Is there any thing i can’t do with Workstation that i can do with ESXI ?

  • aussiewilliams

    I am following an online course using autolabs. I am trying to install Win2012R2 to the DC VM (downloaded end October 2016). Does not matter what I do, windows unattended setup asks to enter the product key even if i add the product key to the autoUnattended.xml file provided on the DC.flp. the setup asks me to manually input the key. I have made subscription and I have tried the standard and the datacenter key. All i get is “we can’t verify the product key. Please check your installation media. my installation media is “en_windows_server_2012_r2_with_update_x64_dvd_6052708.iso” IO am using VMware Fusion 8.5.1 on Mac. I have tried connecting LAN as bridged, disconnected LAN but I still cannot get past this error.

    Here is my autoUnattended.xml:

    true

    Lab

    Lab.local

    XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

    Never

    I googled but can only find people complaining about this without a solution.

    TIA

    aussie

  • Raff Poltronieri

    Hi Alastair, great job!
    What should I change for a Ravello deployment of 2 Autolabs, in order to have 2 separate vCenter simulating 2 DC separate geographically? IP of course… anything else, surely inside scripting?
    Thank you
    Raff

  • isotonic uk

    Hi I am using AutoLab 2.6 using vCenter 6.0 however my vCenter is not getting installed on the VC build. DC build is working as expected and has SQL 2012 databases ready for VC.
    It did complain about PowerCLI, I installed this manually however still having the problems, even If I try to run build.cmd file from B:AutomateVC and run it within the Windows powershell or even with vSphere Powercli it still fails. I notice when I run build.cmd it runs in WIndows powershell by default, is this normal? the error I am getting seems to be it cant recognise the command which I would expect as they are VMware commands.

    ANy advice on this would be greatly appreciated.

    Thanks

  • Wally

    Has there been an update to using ESXi 6.5?

  • Arun Sharma

    Hi, Thanks for uploading labs , I am getting error while installing Windows server 2012, Windows can’t read the Productkey from the unattend answer file.

  • Smart Canuck

    I’m using auto lab 2.6 on Ravello. The DC and VC configs looks good after I check with the validation script. However I’m unable to add hosts to the VC. I keep getting the following error:

    host1.lab.local

    Get-VMHost : 4/23/2017 3:15:48 PM Get-VMHost VMHost with name ‘host1. lab.local’ was not found using the specified filter(s). At C:AddHosts.ps1:198 char:21 + While ((Get-VMHost <<<< $VMHost).ConnectionState -ne "Connected"){ + CategoryInfo : ObjectNotFound: (:) [Get-VMHost], VimException + FullyQualifiedErrorId : Core_OutputHelper_WriteNotFoundError,VMware.VimA utomation.ViCore.Cmdlets.Commands.GetVMHost

    Please let me know asap how can I fix it. My Ravello trial will end soon.