• What do you think about the “new forum” software? any tips to improved it?

  • Steve

    It’s been some time since I was last at this site, format has changed fairly drastically. Where are all the different discussion topics?

  • Jeroen Lokerse

    I’m having trouble building the Vc vm, i does not join the domain. I can’t even join it manually. I can ping the dc. It keeps giving an error that it can’t find a domain controller.

  • My Build share dose not have ISO images on it, the size of the folder is 0MB. Can some one assist on this please_

  • Austin

    I cant get the Update Manager to work properly. I added the route via the script on the VC box and I setup the default route on the freesco server with the gateway being my gateway used for other machines outside of my lab.

    I ended up just adding another NAT NIC to the VC server to get access to the internet. Has anyone else had this problem getting routing to the internet for the update manager?



  • Austin

    I’m also having an issue with installing SQL Management Studio. I’m dropping the SQLManagementStudio_x64_ENU.exe into the NAS share so it auto installs. I get prompted during the DC box install that there is a compatibility issue with the studio version. I proceed with the install and the script prompts that the install is successful.

    After the server is ready to go, the management studio is not actually installed. When I try to run the install manually I get the following error: “Invoke or BeginInvoke cannot be called on a control until the window handle has been created”. I googled the error and what I found is that I need to upgrade my version of SQL Express (no other easier/obvious fixes worked that I tried). I ran the upgrade and received the same error… So I’m unable to view the DB’s on the DC box as I don’t have enough disk space to spin up another workstation VM for management apps.


  • independent_forever

    Awesome lab but HA in the 2 host cluster isn’t working for me. Can’t initialize and I’ve tried removing the hosts, adding them back into the cluster, turning HA off, etc…no luck. Anyone else have suggestions?

  • Michael Noe

    Has anyone had troubles on the automated VC install where you get error 25003 failed to create the vcenter server repository?

  • Jim Kirn

    Excellent! – I was able to build Autolab on an ESXi server. Now have the base NAS, two hosts, DC, VC fully functional.

  • Jim Kirn

    I did get one error on the VC install – Windows XP SysPrep missing. Not sure what to do about it. Could not find anything in the Autolab instructions.

  • Jim Kirn

    Thanks for your quick reply!

  • Scott Driver

    HELP: I’m very eager to get my lab up so I can work towards my VCP delta. The DC setup ran without issue, but when attempting to build the hosts, I’m running into an error where it’s not seeing the disks. Having the hosts auto-install an get an error saying “no suitable disk was found”. If I choose to do it manually, the installer shows no local or remote disks. Upgrading the vm version does not help, but I’m a little hesitant to continue mucking with the VM further.
    Thanks in advance!

    vmware workstation 9
    ESXi 5.5.0

    • Scott Driver

      so adding additional scsi disks has no effect. I can add an IDE disk and it is recognized. I guess I’d just like to understand the impact on later activities if I go down the IDE path….

      • scott driver

        I’m able to boot to the ISO and install manually from there. I’m going to continue hacking at this to see if I can get the automation working.

  • Simon

    Hello, can someone please tell me the default username and password login to the router. I couldn’t find the information the deployment guide. Thanks

    • lexone

      like any linux based OS the default login username is: root
      the password is the same as the default used for vi-admin account

      • Simon

        Thanks for a quick reply.

  • Simon

    Hello, I am having issue with building the lab. I think the only issue I am having is “No SQL Express Installer Found” but I do have the Installer file in my NAS and for some reason, it can’t see it there. Please check my buildlog and give me some advise, I also included the screenshot of my SQL Express Installer file from my NAS. Thanks

    1 file(s) copied.


    * Autolab V1.5


    * Released February 2014


    * New versions and updates at http://www.labguides.com


    * Install DHCP

    * Enable DHCP

    The operation completed successfully.

    1 file(s) copied.

    Checking if Active Directory Domain Services binaries are installed…

    Active Directory Domain Services binaries are being installed. Please wait…

    Active Directory Domain Services Setup

    Validating environment and parameters…

    A delegation for this DNS server cannot be created because the authoritative parent zone cannot be found or it does not run Windows DNS server. If you are integrating with an existing DNS infrastructure, you should manually create a delegation to this DNS server in the parent zone to ensure reliable name resolution from outside the domain “lab.local”. Otherwise, no action is required.


    The following actions will be performed:

    Configure this server as the first Active Directory domain controller in a new forest.

    The new domain name is “lab.local”. This is also the name of the new forest.

    The NetBIOS name of the domain is “LAB”.

    Forest Functional Level: Windows Server 2003

    Domain Functional Level: Windows Server 2003

    Site: Lab

    Additional Options:

    Read-only domain controller: “No”

    Global catalog: Yes

    DNS Server: Yes

    Create DNS Delegation: No

    Database folder: C:WindowsNTDS

    Log file folder: C:WindowsNTDS

    SYSVOL folder: C:WindowsSYSVOL

    The DNS Server service will be installed on this computer.

    The DNS Server service will be configured on this computer.

    This computer will be configured to use this DNS server as its preferred DNS server.

    The password of the new domain Administrator will be the same as the password of the local Administrator of this computer.



    Performing DNS installation…

    Press CTRL-C to: Cancel

    Waiting for DNS installation to finish

    Waiting for DNS Server service to be recognized… 0

    Waiting for DNS Server service to start… 0

    Checking if Group Policy Management Console needs to be installed…

    Installing Group Policy Management Console…

    Configuring the local computer to host Active Directory Domain Services

    Creating directory partition: CN=Schema,CN=Configuration,DC=lab,DC=local; 1585 objects remaining

    Creating directory partition: CN=Configuration,DC=lab,DC=local; 1419 objects remaining

    Creating directory partition: CN=Configuration,DC=lab,DC=local; 1155 objects remaining

    Creating directory partition: CN=Configuration,DC=lab,DC=local; 731 objects remaining

    Creating directory partition: CN=Configuration,DC=lab,DC=local; 388 objects remaining

    Creating directory partition: CN=Configuration,DC=lab,DC=local; 107 objects remaining

    Creating directory partition: DC=lab,DC=local; 0 objects remaining

    Configuring service IsmServ

    Setting security on the domain controller and Directory Service files and registry keys

    Securing machinesystemcurrentcontrolsetserviceswintrust

    The attempted domain controller operation has completed

    Configuring the DNS Server service on this computer…

    Enabling Active Directory Web Services if necessary …

    Configuring Encrypting File System Services …

    Active Directory Domain Services is now installed on this computer for the domain “lab.local”.

    This Active Directory domain controller is assigned to the site “Lab”. You can manage sites with the Active Directory Sites and Services administrative tool.

    Windows Server 2008 and “Windows Server 2008 R2” domain controllers have a new more secure default for the security setting named “Allow cryptography algorithms compatible with Windows NT 4.0.” This setting prevents Microsoft Windows and non-Microsoft SMB “clients” from using weaker NT 4.0 style cryptography algorithms when establishing security channel sessions against Windows Server 2008 or “Windows Server 2008 R2” domain controllers. As a result of this new default, operations or applications that require a security channel serviced by Windows Server 2008 or “Windows Server 2008 R2” domain controllers might fail.

    Platforms impacted by this change include Windows NT 4.0, as well as non-Microsoft SMB “clients” and network-attached storage (NAS) devices that do not support stronger cryptography algorithms. Some operations on clients running versions of Windows earlier than Windows Vista with Service Pack 1 are also impacted, including domain join operations performed by the Active Directory Migration Tool or Windows Deployment Services.

    For more information about this setting, see Knowledge Base article 942564 (http://go.microsoft.com/fwlink/?LinkId=104751).


    * Autolab V1.5


    * Released February 2014


    * New versions and updates at http://www.labguides.com


    * Starting PowerShell script for Phase 2 completion

    Installing 7-zip.

    Installation of 7-zip completed.

    Installing TFTP.

    Creating C:TFTP-Root directory.

    Creating C:Program FilesTftpd64_SE directory.

    Setting TFTP service startup type and starting it.

    Copying B:AutomateDCTFTP-Root contents to C:TFTP-Root.

    Installation of TFTP completed.

    Checking for VMware Tools…

    VMware Tools found.

    Checking for vSphere files…

    Extracting ESXi 5.5 installer from ISO.

    ESXi 5.5 found; creating C:TFTP-RootESXi55 and copying ESXi 5.5 boot files.

    Adding ESXi 5.5 option to PXE menu

    ESXi 5.5 added to TFTP and PXE menu.

    Checking for vCenter files…

    vCenter 5.5 found.

    vSphere 4.1 installation requirements not met. Please verify that both vCenter 4.1 & ESXi 4.1 exist on Build share.

    vSphere 5.0 installation requirements not met. Please verify that both vCenter 5.0 & ESXi 5.0 exist on Build share.

    vSphere 5.1 installation requirements not met. Please verify that both vCenter 5.1 & ESXi 5.1 exist on Build share.

    Checking for vCloud files…

    Authorise and configure DHCP

    Create DNS Records

    Setup Users

    Checking available SQL Express versions.

    No SQL Express installers found. Please verify that all contents of vCenter ISO are copied into the correct folder on the Build share.

    • lexone

      Looks like the correct file and I assume you added that extra SQLEXPR file but it’s not needed. Which build of ESXi 5.5 are you trying to deploy? Also, just looking at your other files, you need to rename your XP, 2K3, PowerCLI files to WinXP.iso, Win2k3.iso and VMware-PowerCLI.exe. I also noticed that you do not have the VMware-vSphere-CLI.exe file. Additionally, you need to extract the contents of the VMware tools iso and place those files in the VMTools folder. You may have done this already but just commenting on what I see from your screen shot. When all else fails, start over. It makes for great practice.

      • Simon

        Lexone, thanks for the information , I have corrected the WinXP.iso and Win2K3.iso also download the VM-vSphere-CLI.exe, I already got the VMware tools iso in the VMTools folder. I have build the lab many times already but for some reason, it doesn’t recognize SQLManagementStudio_x64_ENU.exe installer file. I can’t get the Validate on my DC because the missing the SQLManagementStudio_x64_ENU.exe installed in the DC? Any suggestion for this missing installer file?

        • lexone

          It’s possible that the file is corrupt for some reason. I did not have any of those issues so I would advise to re-download the file. If it still doesn;t work, I can share my file with you via dropbox or something. As for the VMware tools, be sure not to just place the ISO in the VMTools folder…that will not work. You need to extract the ISO (same as you had to do with the ESXi ISOs) and place the extracted contents into the folder. Let me know if you still have issues. :)

  • Matt

    Trying to install player according to the labguide and it does not like “rundll32.exe vmnetui.dll VMNetUI_ShowStandalone” fails to start saying the vmnetui.dll module could not be found. Any body else with this problem?

  • Stefano De Bellis

    Getting the error below when setting up the VCenter; (see attached image), version of VCenter is 5.5 and it’s size is 3.42 gigs.

    • pisymbol

      I am getting the same error. Were you able to find resolution? Thanks.

      • lexone

        Please see reply above to Stefano De Bellis…

    • lexone

      I had this same problem – and sorry no one has responded to you – but this has been answered in the support forum by Martin Rennex (http://www.labguides.com/forums/autolab-support/) – I took his advice and added some extra lines to the build script to take care of this for me in advance. But here is some of his post:

      1. Make sure you use the non-rollup iso of ESXi 5.5 U2. The DC and ESXi hosts should build ok.
      2. During the VC auto build if the SSO install fails with a “DLL not found” error then press CTRL-C to exit the script, and exit the error dialog. Run “vcredist_x64.exe” and “vcredist_x86.exe” from the \ Sign-Onprerequisites folder.
      3. Start the VC script again by running \, make sure to right click and “Run as Administrator”. You will get a PowerCLI error, press ENTER to continue.
      4. The VC and all modules should install correctly now.

  • Stefano De Bellis

    Has anyone encountered issue below? If so how was it resolved.
    Thank you in advance.

  • pisymbol

    Greetings: Getting error while installing hosts:

    Error (See Long for more info):
    cannot open file
    [Error 2] No such file or directory: ‘/tardisks/xhci_xhc_v00’

    I am using Workstation 10 and trying to install ESXi 5.5.

    While looking at the TFTP-Root directory I do see xhci_xhc_v00 file.

    Attaching some logs here if that helps.


  • Stefano De Bellis

    I believe it may be a bug with the latest version of VCenter, I used an older version of VCenter 5.5 and it worked. (the date of my installation files are April 16 2014.

    • pisymbol

      Okay, how did you change image on TFTP server?

      • Stefano De Bellis

        All I did was extract the VCenter ISO to the VIM5.5 folder on the NAS, not sure what you mean about the TFTP server.

        • pisymbol

          Thanks. By the way, It seems like I got 5.5 build working with Margiin Rennix’s Instruction under support forum.

          • Stefano De Bellis

            Fantastic, great timing since i’m rebuilding my lab.


          • Stefano De Bellis

            Hi Pisymbol, I followed the instructions by Margiin Rennix, but what does he mean on #6 (6. Add LABadministrators to the Adminstrator role at the VC level.).

  • Samcara

    Guys, I am getting the following error while installing ESXi 55 with autolab automation:

    An error has occurred while parsing the installation script.

    VALIDATE_HOST_HW ERROR: vendor VIB for HP found, but host is VMware, Inc.

    But when I manually mount the same ESXi 5.5 ISO I had extracted in \, to a VM I manually built I can install a nested ESXi 5.5 host. Your help is appreciated.
    I am running all the lab on a physical ESXi on HP DL160

    • Samcara

      Has anyone encountered the issue I just described above?

  • Leo Roscoe

    Where can I download the additional software needed to populate the build share?

    • lexone

      Piracy is not supported nor promoted
      http://www.vmware.com & from Microsoft – are your sources for media

      • Leo Roscoe

        I know piracy is not supported or promoted. I was just having a hard time downloading it from vmware that’s all. So I thought maybe someone had suggestions. I figured it out

        • lexone

          Great! glad you were able to get what you needed. Please don’t take previous comment out of context, just had to put that out there so other readers are aware. I don’t maintain this site, I’m just a fellow user helping others :)

  • Shane

    Any solution to the VCenter SSO set-up error?

    • lexone

      Please see reply above to Stefano De Bellis…

  • Brian

    Just getting started and when I attempt to install Server 2008 onto my DC, the autounattend file does not seem to automate the install. I get the initial Server setup screen that allows me to pick which flavor of Server to use and it just sits there. I can manually go through and install Server 2008 onto my DC but documentation seems to insinuate that the initial setup of Server 2008 and further configurations will be automated. Using the latest auto-lab software and double-checked to make sure that my NAS is on and is setup according to Task 1. Thanks!